Node status updates are delayed

Incident Report for Netdata

Resolved

This incident has been resolved.
Posted May 12, 2023 - 08:42 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 12, 2023 - 08:33 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 12, 2023 - 07:30 UTC

Investigating

We had a problem with updating node status on Cloud UI. In practice it means that there was a delay between node changing status from for example online to offline and cloud realising this fact. This would also affect new agents or deleting an existing one.
Due to connection update delay there is also a delay in chart metadata updates in our database with which we are dealing right now. This on the other hand from user perspective means, that charts for newly installed applications or charts in general for new nodes are not yet showing up on the Cloud UI.
Posted May 12, 2023 - 07:30 UTC
This incident affected: Cloud Web UI.