Agent v2.7.0 on Windows doesn't start go.d plugin

Incident Report for Netdata

Resolved

This incident has been resolved.
Posted Sep 30, 2025 - 18:29 UTC

Monitoring

We have released Netdata Agent v2.7.1 and recommend all Windows users to upgrade.

Release notes: https://github.com/netdata/netdata/releases/tag/v2.7.1
Posted Sep 30, 2025 - 05:04 UTC

Identified

We've identified an issue with the latest Agent release on Windows that causes the go.d plugin to not be started. The impact is that for Windows nodes, none of the metrics from the go.d plugin are being collected and corresponding alerts don't fire.

We will be releasing a patch release to address this as soon as possible today.

As a workaround the plugin binary in Program Files can be renamed to add the missing .exe extension.
Posted Sep 29, 2025 - 11:36 UTC
This incident affected: Agent (all platforms).